FreeWeldingForum.com 
Welding Forum Community presented by LONGEVITY
877 - Long - Inc | 877.566.4462
Results 1 to 3 of 3

Thread: Welder won't feed wire

  1. #1

    Welder won't feed wire

    I have a Eastwood MIG 135, which looks like a clone of the 140, and it will not feed the wire. There is a green and red led on the pcb, green stays lit and the red goes out when the torch trigger is squeezed. Red comes back on in a few seconds. Gas solenoid clicks with trigger. No power going to drive motor. Is there a schematic available or some way to check voltage on pcb connections?

  2. #2
    Quote Originally Posted by Jim 6648 View Post
    I have a Eastwood MIG 135, which looks like a clone of the 140, and it will not feed the wire. There is a green and red led on the pcb, green stays lit and the red goes out when the torch trigger is squeezed. Red comes back on in a few seconds. Gas solenoid clicks with trigger. No power going to drive motor. Is there a schematic available or some way to check voltage on pcb connections?
    Hello

    We do not sell eastwood machines, but I know they look similar. I can offer you our schematic and you can cross-reference with the Eastwood machine you have. I know we request and modify our machines to the max with premium parts. So there may be some variations inside. If it helps, email tech@lwelds.com for the schematic.
    Longevity Welding
    Toll-Free Support: 1-510-887-7090 / 1-877-566-4462
    Business Hours: Monday-Friday 8AM to 4PM

  3. #3
    Thanks for reply and schematic offer, I sent the email, I'll post my findings.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •