FreeWeldingForum.com 
Welding Forum Community presented by LONGEVITY
877 - Long - Inc | 877.566.4462
Results 1 to 7 of 7

Thread: New to welding, trying to set up my Eastwood mig 135, now I have no arc

  1. #1

    New to welding, trying to set up my Eastwood mig 135, now I have no arc

    Trying to set up my new Eastwood 135 w/t spool gun for welding aluminum. Felt like we were getting pretty close, and poof, now the welder won't throw and arc. Have tried cleaning up the material, adjusting the ground clamp, checking the ground and spool gun connection, changing the settings. Nothing works. Every now and again, it will flicker, but very inconsistent. The fan on the welder still comes on, and the spool gun still feeds wire. Just no arc. I'm pretty new to this, so hoping its something simple, but getting frustrated. Appreciate any help.

    Thanks

  2. #2
    Does the welder work when you run it without the spool gun? If so I suspect your cable has a break in it or possibly a bad internal connection on the hot lead.
    Units owned Longevity PROmts 200

    Force Cut LP80 plasma cutter
    Longevity auto dark welding helmet

    Atlas 10x36" lathe
    Craftsman 5HP 30 Gal compressor
    Home made CNC router/plasma/hot wire foam cutting, 3D printing table powered by Longevity Force Cut LP80
    Home built aluminum foundry, HF 4x6 bandsaw

  3. #3
    Gadget,
    Thanks for the reply. I was curious about that, but was hoping it was something simple I wasn't thinking about.
    I'll try that and get back.

  4. #4
    Gadget,
    I'm running the welder off an extension cord, going in, my only concern was loss of amperage. Is it possible this contributed to my issues?

  5. #5
    gadget, hooked my mig torch, runs perfect. Looks like my issues are linked to the spool gun.

  6. #6
    Run a continuity test with an ohm meter between the hot lead connection at the plug of the spool gun to the tip of the spool gun, I'll bet there is a break somewhere along the line.
    Units owned Longevity PROmts 200

    Force Cut LP80 plasma cutter
    Longevity auto dark welding helmet

    Atlas 10x36" lathe
    Craftsman 5HP 30 Gal compressor
    Home made CNC router/plasma/hot wire foam cutting, 3D printing table powered by Longevity Force Cut LP80
    Home built aluminum foundry, HF 4x6 bandsaw

  7. #7
    Hey pete, I had this kind of problem too. Replaced my spool gun and it worked.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •