FreeWeldingForum.com 
Welding Forum Community presented by LONGEVITY
877 - Long - Inc | 877.566.4462
Results 1 to 2 of 2

Thread: Tig Machine shorts out when using foot pedal

  1. #1

    Question Tig Machine shorts out when using foot pedal

    Hi all, So I've got an older Longevity Weldmax 164i, probably around 7 years old. My grandfather bought it and ended up only using it two or three times and gave it to me just recently. I've had issues with the foot pedal from day 1 never did it come down below 90 amps no matter what i did, so i replaced the potentiometer with a 22k Ohm single turn pot and soldered it back together and it still wont reliably come down to lower amperage. anyways, thats besides the point, when i go to strike and arc the HF kicks in and it lights up almost immediately but then after a 1/4 of a second the machine throws the duty cycle light and it cuts out, then I'm forced to power down the machine and turn it back on to be able to use it again. The machine does this every time i try to weld using the foot pedal, the torch switch works fine but i'd really love to be able to use the machine with a foot pedal. stick welding function works fine and the plasma function works okay, generally have to scratch start the plasma not enough pilot arc strength to do much. If anyone has any input on what the issue might be i'm all ears.

    Thanks, Tyson

  2. #2

    Same here

    Quote Originally Posted by tysoo2 View Post
    Hi all, So I've got an older Longevity Weldmax 164i, probably around 7 years old. My grandfather bought it and ended up only using it two or three times and gave it to me just recently. I've had issues with the foot pedal from day 1 never did it come down below 90 amps no matter what i did, so i replaced the potentiometer with a 22k Ohm single turn pot and soldered it back together and it still wont reliably come down to lower amperage. anyways, thats besides the point, when i go to strike and arc the HF kicks in and it lights up almost immediately but then after a 1/4 of a second the machine throws the duty cycle light and it cuts out, then I'm forced to power down the machine and turn it back on to be able to use it again. The machine does this every time i try to weld using the foot pedal, the torch switch works fine but i'd really love to be able to use the machine with a foot pedal. stick welding function works fine and the plasma function works okay, generally have to scratch start the plasma not enough pilot arc strength to do much. If anyone has any input on what the issue might be i'm all ears.

    Thanks, Tyson
    Same problem on older 200pi
    I tried a different pedal but its in the machine itself.
    I have never used a foot pedal so don't know what I'm missing. Or care really.
    You could hook up a control cable, like a bicycle brake cable to the amp knob on the machine and do it physically.
    Some guys do that with the cheaper HF tigs.

    I learned to tig without foot control, so whatever.
    You could also try the tig gun with adjustable knob on the gun.
    South Bend 9"x36" Precision Model A. Woohoo!
    Sherline lathe and vert mill.
    Weller soldering gun.
    Pair of pliers.
    Some glue.
    Lincoln mig Weldpac 100.
    200PI tig .
    An extention chord.
    And a boat.
    HF 21 Gal vertical compressor.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •