FreeWeldingForum.com 
Welding Forum Community presented by LONGEVITY
877 - Long - Inc | 877.566.4462
Results 1 to 3 of 3

Thread: Stickweld 140 amperage problem

  1. #1

    Stickweld 140 amperage problem

    The stickweld 140 is supposed to have an amperage range from 30 to 140 .

    When I set the dial at the lowest point the digital readout shows 20 amps.

    Why is there a 10 amp difference ?

  2. #2
    Hello Dee, has the range been this way since new or is this an issue that has recently developed. Sometimes new machines can be bumped around enough during shipping that the wiring harness running from the control board to the display is loosened and this can cause a value discrepancy. One can check this by disconnecting the machine from a power source, waiting 10 min and then removing the cover and making sure the wiring harness is secure at the back of the display.

    If this does not solve the issue, more information and trouble shooting will be required. You can contact us by phone at 877-566-4462 to speak with a technician between the hours of 8AM and 1:30PM PST or email us at Tech@lwelds.com.

  3. #3
    This is a new problem. When I bought the unit in May 2016 the readout was correct.

    I opened the box and snugged down the ends of the plugs for the display. I didn't notice any looseness in the fit but when I turned the unit back on the display was back at 30 amps for the low reading.

    Thanks for the help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •