FreeWeldingForum.com 
Welding Forum Community presented by LONGEVITY

Search:

Type: Posts; User: amessina

Page 1 of 2 1 2

Search: Search took 0.01 seconds.

  1. Replies
    8
    Views
    5,844

    I gave the unit away to a poor soul who is going...

    I gave the unit away to a poor soul who is going to try to fix it. I still have the pedal and the WP-26 torch if anyone is interested. I am keeping the PC torch because I want to buy one and a...
  2. Replies
    8
    Views
    5,844

    Nobody interested in FREE parts?

    Nobody interested in FREE parts?
  3. Replies
    9
    Views
    5,398

    do you repair them? My LS-200PI needs help but...

    do you repair them? My LS-200PI needs help but Longevity in Hayward doesn't know what to do. They have no schematics or parts....and it is only 5 yrs old!! Any help is appreciated
  4. Replies
    7
    Views
    4,308

    My WeldAll 200 sat for 3 months and it never...

    My WeldAll 200 sat for 3 months and it never started back up. Turned into trash and Longevity can't fix it
  5. Jesse said that it is not worth the shipping cost...

    Jesse said that it is not worth the shipping cost back and forth to Hayward plus the diagnostics because he has no schematics for the "Blue Models". It is not clear what parts are needed. No boards...
  6. Replies
    5
    Views
    4,273

    Mine is 5 yrs old (S/N 20901238) and it is...

    Mine is 5 yrs old (S/N 20901238) and it is "unrepairable" per Jesse. No parts. No schematics. It sat for 3 months and then....no power. It was awesome while it lasted. Sure hate to scrap it.
  7. Thread: 5 year review

    by amessina
    Replies
    2
    Views
    3,961

    I had a similar experience 5 yrs ago when I...

    I had a similar experience 5 yrs ago when I purchased the machine from Jesse. Killer deal with added consumables etc but now "old blue" (LS-200PI) is very anemic (arc with no power) and neither...
  8. Replies
    5
    Views
    3,623

    Interesting....I left messages after speaking to...

    Interesting....I left messages after speaking to tech support and "he is not in but will call you as soon as he gets in"......He must be really busy
  9. Replies
    14
    Views
    11,456

    Whatever you do, don't let it sit. 3 months of...

    Whatever you do, don't let it sit. 3 months of rest killed my WeldAll 200PI....and it was only 5yrs old!!! I am waiting on Daniel to call me about a replacement and this one would be nice. Thank...
  10. Really Daniel? I spoke to Jesse (Tech Support}...

    Really Daniel? I spoke to Jesse (Tech Support} and he said that you have no schematics or parts for my 5 year-old LS-200PI used by a garage hobbyist (<200 hrs in 5 yrs). Your only technician is...
  11. Replies
    8
    Views
    5,844

    LS-200PI Parts

    Since my LS-200PI cannot be fixed, well, maybe someone can use it for parts.
    Contact me if any of my parts can be of any use to you.
    Let me know if there are any schematics out there. Jesse tried...
  12. Thread: Argon Leaks

    by amessina
    Replies
    9
    Views
    8,708

    I discovered that the 220V argon solenoid and the...

    I discovered that the 220V argon solenoid and the regulator inside my LS-200PI use fittings with 3/16" barb x 1/8" NPT. Those fittings are available thru Grainger and Ace Hardware. The 8 mm x 5 mm...
  13. Replies
    23
    Views
    21,018

    the 470 ohm resistor was open so I replaced it...

    the 470 ohm resistor was open so I replaced it and it is all back together. Also I was chasing argon leaks which have been going on since brand new and discovered that the fittings on the solenoid...
  14. Replies
    23
    Views
    21,018

    my pedal problem is fixed!! The 470 ohm resistor...

    my pedal problem is fixed!! The 470 ohm resistor is correct and all pots check correctly as Gadget suggested. So life is good again. Thank you all for the help
  15. Replies
    23
    Views
    21,018

    do you know which SCC pedal is compatible with...

    do you know which SCC pedal is compatible with the Longevity welders? my pedal has maybe atotal of 30 hrs and it needs repair already so i am reluctant to buy another one like it.. any help is...
  16. Replies
    23
    Views
    21,018

    I tried the pedal with the 470 ohm resistor and...

    I tried the pedal with the 470 ohm resistor and it works somewhat. The arc seems to sputter a bit when it starts but settle down to "normal" after a few seconds (~5 or so). The display changes as I...
  17. Replies
    23
    Views
    21,018

    How risky do you think it is to use it with the...

    How risky do you think it is to use it with the wrong resistor in it? Longevity tech support knows nothing about it and they just want to sell me a BLACK machine because my BLUE one is outdated and...
  18. Replies
    23
    Views
    21,018

    I'll see if my camera on MACRO setting can take a...

    I'll see if my camera on MACRO setting can take a shot of it the last band is separated from the others so I suspect that one is the tolerance band.
  19. Replies
    23
    Views
    21,018

    KHK, In trying to troubleshoot my pedal problem...

    KHK,
    In trying to troubleshoot my pedal problem described further down, I discovered a resistor that appears to be 470 ohnm on the green wire right at the terminal of the potentiometer. The resistor...
  20. Replies
    23
    Views
    21,018

    Using the circuit that KHK had posted, I...

    Using the circuit that KHK had posted, I discovered an open resistor on the GREEN wire of PIN 3. The resistor appears to be a 470 ohm, 2% (yellow/purple/black/black/red)which I replaced with one of...
  21. Replies
    23
    Views
    21,018

    Thank you Gadget. Is there a way to put a switch...

    Thank you Gadget. Is there a way to put a switch on the wire to "de-activate" the pedal so I can use the PULSE function without unplugging the pedal? As you recall, the LS-200PI won't pulse if the...
  22. Replies
    23
    Views
    21,018

    Yesterday the pedal on my LS-200PI started a new...

    Yesterday the pedal on my LS-200PI started a new "behavior" that I can't explain. I can set the front pot at 7 and it starts OK but as soon as I lift my foot to stop the current, the welder goes to...
  23. Thread: Argon Leaks

    by amessina
    Replies
    9
    Views
    8,708

    the fittings are part of the solenoid unit. i...

    the fittings are part of the solenoid unit. i wonder if Longevity will see parts
  24. Thread: Argon Leaks

    by amessina
    Replies
    9
    Views
    8,708

    Argon Leaks

    Hello to everyone. I have used my LS-200PI for a couple of years to weld some metal art (steel and stainless) but really never managed to stop all the INTERNAL Argon Leaks. So I decided to post a...
  25. Wookie which college in SoCa[ are you referring...

    Wookie which college in SoCa[ are you referring to for weld tests? classes?
    Any info is greatly appreciated Andy M,
Results 1 to 25 of 44
Page 1 of 2 1 2